Foro Formación Hadoop

 
 
Imagen de José Javier Solvas Morcillo
Error al ejecutar un Workflow de Oozie en Hue
de José Javier Solvas Morcillo - viernes, 22 de diciembre de 2017, 17:42
 

Buenas tardes,

En la fase final de la demostración del vídeo sobre Hue 4, después de guardar el Workflow y ejecutarlo, me aparece el siguiente error:

 

{ "traceback": [ [ "/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.6.10-py2.6.egg/django/core/handlers/base.py", 112, "get_response", "response = wrapped_callback(request, *callback_args, **callback_kwargs)" ], [ "/usr/lib/hue/build/env/lib/python2.6/site-packages/Django-1.6.10-py2.6.egg/django/db/transaction.py", 371, "inner", "return func(*args, **kwargs)" ], [ "/usr/lib/hue/apps/oozie/src/oozie/decorators.py", 113, "decorate", "return view_func(request, *args, **kwargs)" ], [ "/usr/lib/hue/apps/oozie/src/oozie/decorators.py", 75, "decorate", "return view_func(request, *args, **kwargs)" ], [ "/usr/lib/hue/apps/oozie/src/oozie/views/editor2.py", 367, "submit_workflow", "return _submit_workflow_helper(request, workflow, submit_action=reverse('oozie:editor_submit_workflow', kwargs={'doc_id': workflow.id}))" ], [ "/usr/lib/hue/apps/oozie/src/oozie/views/editor2.py", 426, "_submit_workflow_helper", "'is_oozie_mail_enabled': _is_oozie_mail_enabled(request.user)," ], [ "/usr/lib/hue/apps/oozie/src/oozie/views/editor2.py", 434, "_is_oozie_mail_enabled", "oozie_conf = api.get_configuration()" ], [ "/usr/lib/hue/desktop/libs/liboozie/src/liboozie/oozie_api.py", 319, "get_configuration", "resp = self._root.get('admin/configuration', params)" ], [ "/usr/lib/hue/desktop/core/src/desktop/lib/rest/resource.py", 100, "get", "return self.invoke(\"GET\", relpath, params, headers=headers, allow_redirects=True, clear_cookies=clear_cookies)" ], [ "/usr/lib/hue/desktop/core/src/desktop/lib/rest/resource.py", 80, "invoke", "clear_cookies=clear_cookies)" ], [ "/usr/lib/hue/desktop/core/src/desktop/lib/rest/http_client.py", 197, "execute", "raise self._exc_class(ex)" ] ] }

 

He investigado problemas similares con errores parecidos pero no se si las respuestas de foros externos también es aplicable a este bug.

¿Cómo podría solucionarlo?

Muchas gracias de nuevo.

Un saludo,

José Javier Solvas

 
Imagen de Admin Formación Hadoop
Re: Error al ejecutar un Workflow de Oozie en Hue
de Admin Formación Hadoop - sábado, 23 de diciembre de 2017, 09:37
 

Buenos días José Javier,

Estamos intentando reproducir el error para darte una solución. 

En tener noticias te decimos algo.

Un saludo,

Imagen de Admin Formación Hadoop
Re: Error al ejecutar un Workflow de Oozie en Hue
de Admin Formación Hadoop - martes, 26 de diciembre de 2017, 09:22
 

Buenos días José Javier,

¿Podrías confirmarnos que tienes todos los servicios necesarios activos antes de ejecutar? Estos son:

 

HDFS, YARN, ZOOKEEPER, HIVE, OOZIE, HUE

 

Muchas gracias.

Un saludo,

Imagen de José Javier Solvas Morcillo
Re: Error al ejecutar un Workflow de Oozie en Hue
de José Javier Solvas Morcillo - miércoles, 27 de diciembre de 2017, 16:09
 

Buenas tardes,

He seguido su consejo y he activado todos los servicios necesarios antes de ejecutar el job y ha desaparecido el mensaje de error que les comenté.

El siguiente problema que tengo es que el job no termina de completarse al 100%. Probablemente mi equipo se quede sin recursos suficientes de memoria RAM para simulaciones sobre este entorno.

Muchas gracias por su ayuda.

Un saludo,

José Javier Solvas